What are the system requirements for iLearn?

Question:

What are the system requirements for iLearn?

Answer:

In order to access Resources and Activities in your online unit, you will need to use a browser such as Firefox or Chrome.

iLearn will operate on the following browsers, it is recommended that you upgrade your browser to the most recent version available for download at:

    •    Firefox

    •    Chrome

    •    Safari